Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "pandas library for high-performance data analysis tools" |
| 2 | DESCRIPTION = "pandas is an open source, BSD-licensed library providing \ |
| 3 | high-performance, easy-to-use data structures and data analysis tools for \ |
| 4 | the Python programming language." |
| 5 | HOMEPAGE = "http://pandas.pydata.org/" |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c1cc9ab35a8b2aabf933cd6d245b5db3" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "220b98d15cee0b2cd839a6358bd1f273d0356bf964c1a1aeb32d47db0215488b" |
| 10 | |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | DEPENDS += " \ |
| 14 | ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \ |
| 15 | " |
| 16 | |
| 17 | CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations" |
| 18 | |
| 19 | RDEPENDS:${PN} += " \ |
| 20 | ${PYTHON_PN}-json \ |
| 21 | ${PYTHON_PN}-numpy \ |
| 22 | ${PYTHON_PN}-dateutil \ |
| 23 | ${PYTHON_PN}-dateutil-zoneinfo \ |
| 24 | ${PYTHON_PN}-pytz \ |
| 25 | ${PYTHON_PN}-profile \ |
| 26 | " |