Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "System load testing utility" |
| 2 | DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \ |
| 3 | imposes a configurable amount of CPU, memory, I/O, and disk stress on the system." |
| 4 | HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme" |
| 5 | LICENSE = "GPL-2.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 9 | file://0001-test-float-Make-variables-global.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 10 | file://0001-Pass-LD_GOLD-1-via-makefile-to-enable-gold-linker.patch" |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 11 | SRCREV = "f3be0447c10fd5652b4c3753d56bcaac13fd8917" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | DEPENDS = "coreutils-native libbsd" |
| 15 | |
| 16 | PROVIDES = "stress" |
| 17 | RPROVIDES:${PN} = "stress" |
| 18 | RREPLACES:${PN} = "stress" |
| 19 | RCONFLICTS:${PN} = "stress" |
| 20 | |
| 21 | inherit bash-completion |
| 22 | |
| 23 | EXTRA_OEMAKE = "VERBOSE=1" |
| 24 | |
| 25 | do_configure() { |
| 26 | mkdir -p configs |
| 27 | touch configs/HAVE_APPARMOR |
| 28 | oe_runmake makeconfig |
| 29 | } |
| 30 | |
| 31 | do_install() { |
| 32 | oe_runmake DESTDIR=${D} BINDIR=${bindir} install |
| 33 | ln -s stress-ng ${D}${bindir}/stress |
| 34 | } |