Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "The PyPA recommended tool for installing Python packages" |
| 2 | sHOMEPAGEsss = "https://pypi.python.org/pypi/pip" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=45665b53032c02b35e29ddab8e61fa91" |
| 6 | |
| 7 | SRCNAME = "pip" |
| 8 | DEPENDS += "python3 python3-setuptools-native" |
| 9 | |
| 10 | SRC_URI = " \ |
| 11 | http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ |
| 12 | " |
| 13 | SRC_URI[md5sum] = "6b19e0a934d982a5a4b798e957cb6d45" |
| 14 | SRC_URI[sha256sum] = "89f3b626d225e08e7f20d85044afa40f612eb3284484169813dc2d0631f2a556" |
| 15 | |
| 16 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 17 | |
| 18 | inherit distutils3 |
| 19 | |
| 20 | DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages" |
| 21 | |
| 22 | do_install_prepend() { |
| 23 | install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages |
| 24 | } |
| 25 | |
| 26 | # Use setuptools site.py instead, avoid shared state issue |
| 27 | do_install_append() { |
| 28 | rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/site.py |
| 29 | rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/__pycache__/site.cpython-34.pyc |
| 30 | } |
| 31 | |
| 32 | RDEPENDS_${PN} = "\ |
| 33 | python3-compile \ |
| 34 | python3-io \ |
| 35 | python3-json \ |
| 36 | python3-netserver \ |
| 37 | python3-setuptools \ |
| 38 | python3-unixadmin \ |
| 39 | python3-xmlrpc \ |
| 40 | " |