blob: 26bfd9c4fab8a346848d7505dc2678ddb8e1f1cc [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Machine-readable files for the SPIR-V Registry"
2SECTION = "graphics"
3HOMEPAGE = "https://www.khronos.org/registry/spir-v"
4LICENSE = "MIT"
Patrick Williams44b3caf2024-04-12 16:51:14 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=d14ee3b13f42e9c9674acc5925c3d741"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06006
Patrick Williams44b3caf2024-04-12 16:51:14 -05007SRCREV = "8b246ff75c6615ba4532fe4fde20f1be090c3764"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008SRC_URI = "git://github.com/KhronosGroup/SPIRV-Headers;protocol=https;branch=main"
9PE = "1"
10# These recipes need to be updated in lockstep with each other:
11# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
12# vulkan-validation-layers, vulkan-utility-libraries.
13# The tags versions should always be sdk-x.y.z, as this is what
14# upstream considers a release.
15UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
16S = "${WORKDIR}/git"
17
18inherit cmake
19
20BBCLASSEXTEND = "native nativesdk"