Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "VirGL virtual OpenGL renderer" |
| 2 | DESCRIPTION = "Virgil is a research project to investigate the possibility of \ |
| 3 | creating a virtual 3D GPU for use inside qemu virtual machines, that allows \ |
| 4 | the guest operating system to use the capabilities of the host GPU to \ |
| 5 | accelerate 3D rendering." |
| 6 | HOMEPAGE = "https://virgil3d.github.io/" |
| 7 | |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=c81c08eeefd9418fca8f88309a76db10" |
| 10 | |
| 11 | DEPENDS = "libdrm libepoxy virtual/egl virtual/libgbm" |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 12 | SRCREV = "690680e5f0f952e22424fca1538c1b24457a0868" |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 13 | SRC_URI = "git://gitlab.freedesktop.org/virgl/virglrenderer.git;branch=main;protocol=https \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 14 | file://0001-meson.build-use-python3-directly-for-python.patch \ |
| 15 | " |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit meson pkgconfig features_check |
| 20 | |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 21 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', 'venus', '', d)}" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 22 | |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 23 | PACKAGECONFIG[venus] = "-Dvenus=true,-Dvenus=false,vulkan-loader vulkan-headers" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 24 | PACKAGECONFIG[va] = "-Dvideo=true,-Dvideo=false,libva" |
| 25 | PACKAGECONFIG[render-server] = "-Drender-server=true,-Drender-server=false" |
| 26 | PACKAGECONFIG[drm-msm-experimental] = "-Ddrm-msm-experimental=true,-Ddrm-msm-experimental=false" |
| 27 | PACKAGECONFIG[minigbm_allocation] = "-Dminigbm_allocation=true,-Dminigbm_allocation=false" |
| 28 | PACKAGECONFIG[venus-validate] = "-Dvenus-validate=true,-Dvenus-validate=false" |
| 29 | PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,libcheck" |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |
| 32 | |
| 33 | REQUIRED_DISTRO_FEATURES = "opengl" |