blob: 0501b0c59cb5b7396a74094b0ac48f4c12f7ce3f [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "VirGL virtual OpenGL renderer"
2DESCRIPTION = "Virgil is a research project to investigate the possibility of \
3creating a virtual 3D GPU for use inside qemu virtual machines, that allows \
4the guest operating system to use the capabilities of the host GPU to \
5accelerate 3D rendering."
6HOMEPAGE = "https://virgil3d.github.io/"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING;md5=c81c08eeefd9418fca8f88309a76db10"
10
11DEPENDS = "libdrm libepoxy virtual/egl virtual/libgbm"
Patrick Williams56b44a92024-01-19 08:49:29 -060012SRCREV = "690680e5f0f952e22424fca1538c1b24457a0868"
Patrick Williamsda295312023-12-05 16:48:56 -060013SRC_URI = "git://gitlab.freedesktop.org/virgl/virglrenderer.git;branch=main;protocol=https \
Andrew Geissler517393d2023-01-13 08:55:19 -060014 file://0001-meson.build-use-python3-directly-for-python.patch \
15 "
16
17S = "${WORKDIR}/git"
18
19inherit meson pkgconfig features_check
20
Patrick Williamsda295312023-12-05 16:48:56 -060021PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', 'venus', '', d)}"
Andrew Geissler517393d2023-01-13 08:55:19 -060022
Patrick Williamsda295312023-12-05 16:48:56 -060023PACKAGECONFIG[venus] = "-Dvenus=true,-Dvenus=false,vulkan-loader vulkan-headers"
Andrew Geissler517393d2023-01-13 08:55:19 -060024PACKAGECONFIG[va] = "-Dvideo=true,-Dvideo=false,libva"
25PACKAGECONFIG[render-server] = "-Drender-server=true,-Drender-server=false"
26PACKAGECONFIG[drm-msm-experimental] = "-Ddrm-msm-experimental=true,-Ddrm-msm-experimental=false"
27PACKAGECONFIG[minigbm_allocation] = "-Dminigbm_allocation=true,-Dminigbm_allocation=false"
28PACKAGECONFIG[venus-validate] = "-Dvenus-validate=true,-Dvenus-validate=false"
29PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,libcheck"
30
31BBCLASSEXTEND = "native nativesdk"
32
33REQUIRED_DISTRO_FEATURES = "opengl"