Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "VLAN provides vconfig utility" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | HOMEPAGE = "http://www.candelatech.com/~greear/vlan.html" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 3 | SECTION = "misc" |
| 4 | LICENSE = "GPLv2" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://vconfig.c;beginline=1;endline=19;md5=094ca47de36c20c598b15b32c270ce0a" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/vlan/1.9-3ubuntu10.6/${BPN}_${PV}.orig.tar.gz \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 8 | file://no-HOME-includes.patch \ |
| 9 | file://0001-Add-printf-format-and-silence-format-security-warnin.patch \ |
| 10 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
| 12 | SRC_URI[md5sum] = "5f0c6060b33956fb16e11a15467dd394" |
| 13 | SRC_URI[sha256sum] = "3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb4868842b4cca" |
| 14 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | UPSTREAM_CHECK_URI = "http://vlan.sourcearchive.com/" |
| 16 | UPSTREAM_CHECK_REGEX = "/(?P<pver>\d+(\.\d+)+)/" |
| 17 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 18 | S = "${WORKDIR}/${BPN}" |
| 19 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 20 | inherit update-alternatives |
| 21 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 22 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 23 | |
| 24 | # comment out MakeInclude in Makefile which sets build environment |
| 25 | do_configure_append () { |
| 26 | sed -i 's/^ include/#^include/' ${S}/Makefile |
| 27 | } |
| 28 | |
| 29 | # ignore strip to avoid yocto errors in stripping |
| 30 | do_compile () { |
| 31 | oe_runmake PLATFORM=ARM 'STRIP=echo' all |
| 32 | } |
| 33 | |
| 34 | do_install () { |
| 35 | install -d ${D}/${base_sbindir} |
| 36 | install -m 0755 ${S}/vconfig ${D}/${base_sbindir}/ |
| 37 | } |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 38 | |
| 39 | ALTERNATIVE_PRIORITY = "100" |
| 40 | ALTERNATIVE_${PN} = "vconfig" |
| 41 | ALTERNATIVE_LINK_NAME[vconfig] = "${base_sbindir}/vconfig" |