blob: 8f028474fd7ba77d55bec6e06f30a60edf692012 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Babel is a loop-avoiding distance-vector routing protocol"
2DESCRIPTION = "\
3Babel is a loop-avoiding distance-vector routing protocol for IPv6 and \
4IPv4 with fast convergence properties. It is based on the ideas in DSDV, AODV \
5and Cisco's EIGRP, but is designed to work well not only in wired networks \
6but also in wireless mesh networks, and has been extended with support \
7for overlay networks. Babel is in the process of becoming an IETF Standard. \
8"
9HOMEPAGE = "https://www.irif.fr/~jch/software/babel/"
10SECTION = "net"
11
12LICENSE = "MIT"
13LIC_FILES_CHKSUM = "file://LICENCE;md5=411a48ac3c2e9e0911b8dd9aed26f754"
14
15SRC_URI = "git://github.com/jech/babeld.git;protocol=git"
16SRCREV = "535184173fcde5ddc43020cd197d01d1ea0e9a8b"
17
18S = "${WORKDIR}/git"
19
20do_compile () {
21 oe_runmake babeld
22}
23
24do_install () {
25 oe_runmake install.minimal PREFIX=${D}
26}
27