Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A user-mode PPPoE client and server suite for Linux" |
| 2 | HOMEPAGE = "http://www.roaringpenguin.com/products/pppoe" |
| 3 | SECTION = "net" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://doc/LICENSE;md5=a194eaefae2be54ee3221339b10d0581" |
| 6 | |
| 7 | PR = "r10" |
| 8 | |
| 9 | SRC_URI = "http://www.roaringpenguin.com/files/download/${BP}.tar.gz \ |
| 10 | file://top-autoconf.patch \ |
| 11 | file://configure_in_cross.patch \ |
| 12 | file://pppoe-src-restrictions.patch \ |
| 13 | file://update-config.patch \ |
| 14 | file://dont-swallow-errors.patch \ |
| 15 | file://discard-use-of-dnl-in-Makefile.am.patch \ |
| 16 | file://configure.patch \ |
| 17 | file://pppoe-server.default \ |
| 18 | file://pppoe-server.init \ |
| 19 | file://configure.in-Error-fix.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 20 | file://pppoe-server.service \ |
| 21 | file://0001-ppoe-Dont-include-linux-if_ether.h.patch \ |
| 22 | file://0002-Enable-support-for-the-kernel-module.patch \ |
| 23 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | |
| 25 | SRC_URI[md5sum] = "216eb52b69062b92a64ee37fd71f4b66" |
| 26 | SRC_URI[sha256sum] = "00794e04031546b0e9b8cf286f2a6d1ccfc4a621b2a3abb2d7ef2a7ab7cc86c2" |
| 27 | |
| 28 | inherit autotools-brokensep update-rc.d systemd |
| 29 | |
| 30 | do_install_append() { |
| 31 | install -d ${D}${systemd_unitdir}/system |
| 32 | install -m 0644 ${WORKDIR}/pppoe-server.service ${D}${systemd_unitdir}/system |
| 33 | sed -i -e 's#@SYSCONFDIR@#${sysconfdir}#g' ${D}${systemd_unitdir}/system/pppoe-server.service |
| 34 | sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/pppoe-server.service |
| 35 | install -d ${D}${datadir}/doc/${PN} |
| 36 | if [ -f ${D}${datadir}/doc/README ]; then |
| 37 | mv ${D}${datadir}/doc/README ${D}${datadir}/doc/${PN}/ |
| 38 | fi |
| 39 | } |
| 40 | |
| 41 | do_install() { |
| 42 | # Install init script and default settings |
| 43 | install -m 0755 -d ${D}${sysconfdir}/default ${D}${sysconfdir}/init.d |
| 44 | install -m 0644 ${WORKDIR}/pppoe-server.default ${D}${sysconfdir}/default/pppoe-server |
| 45 | install -m 0755 ${WORKDIR}/pppoe-server.init ${D}${sysconfdir}/init.d/pppoe-server |
| 46 | # Install |
| 47 | oe_runmake -C ${S} DESTDIR=${D} docdir=${docdir} install |
| 48 | chmod 4755 ${D}${sbindir}/pppoe |
| 49 | } |
| 50 | |
| 51 | SYSTEMD_PACKAGES = "${PN}-server" |
| 52 | SYSTEMD_SERVICE_${PN}-server = "pppoe-server.service" |
| 53 | SYSTEMD_AUTO_ENABLE = "disable" |
| 54 | # Insert server package before main package |
| 55 | PACKAGES = "${PN}-dbg ${PN}-server ${PN}-relay ${PN}-sniff ${PN} ${PN}-doc" |
| 56 | |
| 57 | FILES_${PN}-server = "${sysconfdir}/default/pppoe-server \ |
| 58 | ${sysconfdir}/init.d/pppoe-server \ |
| 59 | ${sbindir}/pppoe-server \ |
| 60 | ${sysconfdir}/ppp/pppoe-server-options" |
| 61 | FILES_${PN}-relay = "${sbindir}/pppoe-relay" |
| 62 | FILES_${PN}-sniff = "${sbindir}/pppoe-sniff" |
| 63 | |
| 64 | CONFFILES_${PN} = "${sysconfdir}/ppp/pppoe.conf \ |
| 65 | ${sysconfdir}/ppp/firewall-standalone \ |
| 66 | ${sysconfdir}/ppp/firewall-masq" |
| 67 | CONFFILES_${PN}-server = "${sysconfdir}/ppp/pppoe-server-options \ |
| 68 | ${sysconfdir}/default/pppoe-server" |
| 69 | |
| 70 | INITSCRIPT_PACKAGES = "${PN}-server" |
| 71 | INITSCRIPT_NAME_${PN}-server = "pppoe-server" |
| 72 | INITSCRIPT_PARAMS_${PN}-server = "defaults 92 8" |
| 73 | |
| 74 | RDEPENDS_${PN} = "ppp" |
| 75 | RDEPENDS_${PN}-server = "${PN}" |
| 76 | RRECOMMENDS_${PN} = "ppp-oe" |
| 77 | |