Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Thumbnail service implementing the thumbnail management D-Bus specification" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 2 | SECTION = "x11/libs" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 5 | DEPENDS = "freetype gdk-pixbuf poppler curl xfce4-dev-tools-native libxml2 libgsf" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | |
| 7 | inherit xfce gtk-doc |
| 8 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 9 | SRC_URI[md5sum] = "5d541608b3962fd2b16e23a266fd7a10" |
| 10 | SRC_URI[sha256sum] = "0999b9a3deb57010956db6630ae7205813999147043171049a7b6c333be93e96" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | |
| 12 | INSANE_SKIP_${PN} = "dev-so" |
| 13 | |
| 14 | PACKAGECONFIG ??= "" |
| 15 | PACKAGECONFIG[gstreamer-thumbnailer] = "--enable-gstreamer-thumbnailer,--disable-gstreamer-thumbnailer,gstreamer1.0 gstreamer1.0-plugins-base" |
| 16 | |
| 17 | do_install_append() { |
| 18 | # Makefile seems to race on creation of symlink. So ensure creation here |
| 19 | # until fixed properly |
| 20 | ln -sf tumbler-xdg-cache.so ${D}${libdir}/tumbler-1/plugins/cache/tumbler-cache-plugin.so |
| 21 | } |
| 22 | |
| 23 | FILES_${PN} += "${datadir}/dbus-1/services \ |
| 24 | ${libdir}/tumbler-1/tumblerd \ |
| 25 | ${libdir}/tumbler-1/plugins/*.so \ |
| 26 | ${libdir}/tumbler-1/plugins/cache/*.so \ |
| 27 | " |
| 28 | |
| 29 | FILES_${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | ${libdir}/tumbler-1/plugins/cache/*.la \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 31 | " |