Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Bluetooth library with attribute support" |
| 2 | SECTION = "libs/network" |
| 3 | |
Patrick Williams | 93c203f | 2021-10-06 16:15:23 -0500 | [diff] [blame^] | 4 | LICENSE = "GPL-2.0+ | BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://CMakeLists.txt;beginline=1;endline=6;md5=71fdd2be76b4e95fe28324a70d4981c5" |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 6 | |
| 7 | DEPENDS = "bluez5 glib-2.0" |
| 8 | DEPENDS += "glib-2.0-native" |
| 9 | |
| 10 | PV = "0.2+git${SRCPV}" |
| 11 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 12 | SRC_URI = "git://github.com/labapart/gattlib.git \ |
| 13 | file://dbus-avoid-strange-chars-from-the-build-dir.patch \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 14 | " |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 15 | |
| 16 | SRCBRANCH = "master" |
Patrick Williams | 93c203f | 2021-10-06 16:15:23 -0500 | [diff] [blame^] | 17 | SRCREV = "fa54ae42ccb3d8f911e00b02ed1e581537e47f79" |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | PACKAGECONFIG[examples] = "-DGATTLIB_BUILD_EXAMPLES=ON,-DGATTLIB_BUILD_EXAMPLES=OFF" |
| 22 | |
| 23 | # Set this to force use of DBus API if Bluez version is older than 5.42 |
| 24 | PACKAGECONFIG[force-dbus] = "-DGATTLIB_FORCE_DBUS=TRUE,-DGATTLIB_FORCE_DBUS=FALSE" |
| 25 | |
| 26 | EXTRA_OECMAKE += "-DGATTLIB_BUILD_DOCS=OFF" |
| 27 | |
| 28 | inherit pkgconfig cmake |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | FILES:${PN} = "${libdir}/*" |
Patrick Williams | 93c203f | 2021-10-06 16:15:23 -0500 | [diff] [blame^] | 31 | FILES:${PN}-dev = "${includedir}/* ${libdir}/pkgconfig" |