Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | require alsa-utils_${PV}.bb |
| 2 | |
| 3 | SUMMARY = "Shell scripts that show help info and create ALSA configuration files" |
| 4 | PROVIDES = "alsa-utils-alsaconf" |
| 5 | |
| 6 | FILESEXTRAPATHS_prepend := "${THISDIR}/alsa-utils:" |
| 7 | |
| 8 | PACKAGES = "${PN}" |
| 9 | RDEPENDS_${PN} += "bash" |
| 10 | |
| 11 | FILES_${PN} = "${sbindir}/alsaconf \ |
| 12 | ${sbindir}/alsa-info.sh \ |
| 13 | ${sbindir}/alsabat-test.sh \ |
| 14 | " |
| 15 | |
| 16 | S = "${WORKDIR}/alsa-utils-${PV}" |
| 17 | |
| 18 | do_install() { |
| 19 | install -d ${D}${sbindir} |
| 20 | install -m 0755 ${B}/alsaconf/alsaconf ${D}${sbindir}/ |
| 21 | install -m 0755 ${S}/alsa-info/alsa-info.sh ${D}${sbindir}/ |
| 22 | if ${@bb.utils.contains('PACKAGECONFIG', 'bat', 'true', 'false', d)}; then |
| 23 | install -m 0755 ${S}/bat/alsabat-test.sh ${D}${sbindir}/ |
| 24 | fi |
| 25 | } |