Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Library and test program for decoding MPEG-2 and MPEG-1 video streams" |
| 2 | HOMEPAGE = "http://libmpeg2.sourceforge.net/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "GPLv2+" |
| 5 | LICENSE_FLAGS = "commercial" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 7 | file://include/mpeg2.h;beginline=1;endline=22;md5=7766f4fcb58f0f8413c49a746f2ab89b" |
| 8 | |
| 9 | SRC_URI = "http://libmpeg2.sourceforge.net/files/libmpeg2-${PV}.tar.gz \ |
| 10 | file://altivec_h_needed.patch \ |
| 11 | file://0001-check-for-available-arm-optimizations.patch \ |
| 12 | file://0002-Set-visibility-of-global-symbols-used-in-ARM-specifi.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | file://61_global-symbol-test.patch \ |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 14 | file://0001-Import-revision-1206-from-upstream-to-fix-PIE-build.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 15 | " |
| 16 | |
| 17 | S = "${WORKDIR}/libmpeg2-${PV}" |
| 18 | |
| 19 | SRC_URI[md5sum] = "0f92c7454e58379b4a5a378485bbd8ef" |
| 20 | SRC_URI[sha256sum] = "dee22e893cb5fc2b2b6ebd60b88478ab8556cb3b93f9a0d7ce8f3b61851871d4" |
| 21 | |
| 22 | UPSTREAM_CHECK_URI = "http://libmpeg2.sourceforge.net/downloads.html" |
| 23 | |
| 24 | inherit autotools pkgconfig |
| 25 | |
| 26 | EXTRA_OECONF = "--enable-shared --disable-sdl" |
| 27 | |
| 28 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
| 29 | PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 libxext libxv" |
| 30 | |
| 31 | PACKAGES = "mpeg2dec-dbg mpeg2dec mpeg2dec-doc libmpeg2 libmpeg2-dev libmpeg2convert libmpeg2convert-dev libmpeg2-staticdev libmpeg2convert-staticdev" |
| 32 | |
| 33 | FILES_${PN} = "${bindir}/*" |
| 34 | FILES_libmpeg2 = "${libdir}/libmpeg2.so.*" |
| 35 | FILES_libmpeg2convert = "${libdir}/libmpeg2convert.so.*" |
| 36 | FILES_libmpeg2-dev = "${libdir}/libmpeg2.so \ |
| 37 | ${libdir}/libmpeg2.la \ |
| 38 | ${libdir}/libmpeg2arch.la \ |
| 39 | ${libdir}/pkgconfig/libmpeg2.pc \ |
| 40 | ${includedir}/mpeg2dec/mpeg2.h" |
| 41 | FILES_libmpeg2-staticdev = "${libdir}/libmpeg2.a" |
| 42 | FILES_libmpeg2convert-dev = "${libdir}/libmpeg2convert.so \ |
| 43 | ${libdir}/libmpeg2convert.la \ |
| 44 | ${libdir}/libmpeg2convertarch.la \ |
| 45 | ${libdir}/pkgconfig/libmpeg2convert.pc \ |
| 46 | ${includedir}/mpeg2dec/mpeg2convert.h" |
| 47 | FILES_libmpeg2convert-staticdev = "${libdir}/libmpeg2convert.a" |