Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Hardware latency detector" |
| 2 | DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)." |
| 3 | HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest" |
| 4 | SECTION = "tests" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 7 | |
| 8 | require rt-tests.inc |
| 9 | inherit python3-dir |
| 10 | |
| 11 | EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages" |
| 12 | |
| 13 | do_compile() { |
| 14 | oe_runmake hwlatdetect |
| 15 | } |
| 16 | |
| 17 | do_install() { |
| 18 | oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \ |
| 19 | MANDIR=${mandir} INCLUDEDIR=${includedir} |
| 20 | |
| 21 | sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py |
| 22 | } |
| 23 | |
| 24 | FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 25 | RDEPENDS_${PN} = "python3-core " |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 26 | RRECOMMENDS_${PN} = "kernel-module-hwlat-detector" |