Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 1 | SUMMARY = "Ninja is a small build system with a focus on speed" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE_Apache_20;md5=19cbd64715b51267a47bf3750cc6a8a5" |
| 4 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 5 | PYPI_PACKAGE = "ninja" |
| 6 | PYPI_ARCHIVE_NAME_PREFIX = "pypi-" |
| 7 | |
| 8 | inherit pypi python_setuptools_build_meta |
| 9 | SRC_URI[sha256sum] = "c833a47d39b2d1eee3f9ca886fa1581efd5be6068b82734ac229961ee8748f90" |
| 10 | |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 11 | SRC_URI += "file://no-scikit-build.patch \ |
| 12 | file://run-ninja-from-path.patch" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 13 | |
| 14 | do_install:append () { |
| 15 | rm -rf ${D}${bindir} |
| 16 | } |
| 17 | |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 18 | RDEPENDS:${PN} = " \ |
| 19 | ninja \ |
| 20 | python3-io \ |
| 21 | python3-json \ |
| 22 | python3-ninja-syntax \ |
| 23 | " |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |