blob: a402f991f732cb0ded926ca65f16291376694591 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "Non-validating SQL parser module"
2HOMEPAGE = "http://pypi.python.org/pypi/sqlparse"
3SECTION = "devel/python"
Andrew Geissler5199d832021-09-24 16:47:35 -05004LICENSE = "BSD-3-Clause"
Andrew Geissler82c905d2020-04-13 13:39:40 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
6
7SRC_URI += "file://0001-sqlparse-change-shebang-to-python3.patch \
Patrick Williams520786c2023-06-25 16:20:36 -05008 file://CVE-2023-30608.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -05009 file://run-ptest \
10 "
11
Andrew Geissler87f5cff2022-09-30 13:13:31 -050012SRC_URI[sha256sum] = "69ca804846bb114d2ec380e4360a8a340db83f0ccf3afceeb1404df028f57268"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14export BUILD_SYS
15export HOST_SYS
16
17inherit pypi ptest setuptools3
18
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 ${PYTHON_PN}-pytest \
21 ${PYTHON_PN}-unixadmin \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
28
29BBCLASSEXTEND = "native nativesdk"