blob: 6f31aea0e09a9d2fbdda4764c1b755071980ce7e [file] [log] [blame]
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05001DESCRIPTION = "A utility provides a fake certificate authority (CA)"
2HOMEPAGE = "https://pypi.org/project/trustme"
3AUTHOR = "Nathaniel J. Smith"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=d5a7af1a4b73e57431e25d15a2da745a"
7
8SRC_URI[md5sum] = "0e4d698e5aecaf8306cf440bf3dcbbe0"
9SRC_URI[sha256sum] = "5e07b23d70ceed64f3bb36ae4b9abc52354c16c98d45ab037bee2b5fbffe586c"
10
11inherit pypi setuptools3 ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
Patrick Williamsb542dec2023-06-09 01:26:37 -050017RDEPENDS:${PN} += " \
18 python3-cryptography \
19 python3-datetime \
20 python3-idna \
21 python3-io \
22"
23
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050024RDEPENDS:${PN}-ptest += " \
25 ${PYTHON_PN}-pytest \
26 ${PYTHON_PN}-service-identity \
27 ${PYTHON_PN}-pyasn1-modules \
28"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/tests
32 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
33 cp -rf ${S}/setup.py ${D}${PTEST_PATH}
34}