Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "USB CEC Adaptor communication Library" |
| 2 | HOMEPAGE = "http://libcec.pulse-eight.com/" |
| 3 | |
| 4 | LICENSE = "GPLv2+" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b3a719e97f49e4841e90573f9b1a98ac" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | DEPENDS = "p8platform udev ncurses swig-native python3" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 9 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}" |
| 10 | DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 12 | SRCREV = "29d82c80bcc62be2878a9ac080de7eb286c4beb9" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | SRC_URI = "git://github.com/Pulse-Eight/libcec.git;branch=release \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 14 | file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | file://0001-Enhance-reproducibility.patch \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 16 | file://0001-Remove-buggy-test-confusing-host-and-target.patch \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 17 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 21 | inherit cmake pkgconfig |
| 22 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 23 | # default config is for RaspberryPi API, use the Linux 4.10+ API by default |
| 24 | PLATFORM_CMAKE_FLAGS ?= "-DHAVE_LINUX_API=1 -DHAVE_RPI_API=0" |
| 25 | EXTRA_OECMAKE += "${PLATFORM_CMAKE_FLAGS}" |
| 26 | |
| 27 | # Put client examples into separate packages |
| 28 | PACKAGE_BEFORE_PN += "${PN}-examples-python ${PN}-examples" |
| 29 | FILES_${PN}-examples-python = "${bindir}/py*" |
| 30 | FILES_${PN}-examples = "${bindir}" |
| 31 | RDEPENDS_${PN}-examples-python = "python3-${BPN} python3-core" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 32 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 33 | # Create the wrapper for python3 |
| 34 | PACKAGES += "python3-${BPN}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 35 | FILES_python3-${BPN} = "${libdir}/python3* ${bindir}/py*" |
| 36 | RDEPENDS_${PN} = "python3-core" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 37 | |
| 38 | # cec-client and xbmc need the .so present to work :( |
| 39 | FILES_${PN} += "${libdir}/*.so" |
| 40 | INSANE_SKIP_${PN} = "dev-so" |
| 41 | |
| 42 | # Adapter shows up as a CDC-ACM device |
| 43 | RRECOMMENDS_${PN} = "kernel-module-cdc-acm" |