kasunath | 951f1aa | 2022-08-10 11:08:14 -0700 | [diff] [blame^] | 1 | # Remove cracklib from PAM, to avoid breaking PAM and further dependencies |
| 2 | # This allows cracklib to be neatly severed from the system. |
| 3 | |
| 4 | EXTRA_OECONF:append:gbmc = " --disable-cracklib" |
| 5 | |
| 6 | DEPENDS:remove:gbmc = "cracklib" |
| 7 | |
| 8 | RDEPENDS:${PN}-runtime:remove:gbmc = "pam-plugin-cracklib-suffix" |
| 9 | |
| 10 | RDEPENDS:${PN}-xtests:remove:gbmc = "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix}" |
| 11 | |
| 12 | do_install:append:gbmc() { |
| 13 | # Remove reference to cracklib library from PAM config file |
| 14 | sed -i '/pam_cracklib.so/d' ${D}${sysconfdir}/pam.d/common-password |
| 15 | } |