Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | DEPENDS = "libusb-compat libftdi" |
| 5 | RDEPENDS_${PN} = "libusb1" |
| 6 | |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 7 | SRC_URI = " \ |
| 8 | git://repo.or.cz/openocd.git;protocol=http;name=openocd \ |
| 9 | git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \ |
| 10 | git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \ |
| 11 | git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \ |
| 12 | file://0001-Add-fallthrough-comments.patch \ |
| 13 | file://0002-Workaround-new-warnings-generated-by-GCC-7.patch \ |
| 14 | file://0003-armv7a-Add-missing-break-to-fix-fallthrough-warning.patch \ |
| 15 | file://0004-Fix-overflow-warning.patch \ |
| 16 | file://0005-command-Move-the-fall-through-comment-to-right-scope.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | " |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 18 | SRCREV_FORMAT = "openocd" |
| 19 | SRCREV_openocd = "1025be363e2bf42f1613083223a2322cc3a9bd4c" |
| 20 | SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba" |
| 21 | SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787" |
| 22 | SRCREV_libjaylink = "699b7001d34a79c8e7064503dde1bede786fd7f0" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 23 | |
| 24 | PV = "0.10+gitr${SRCPV}" |
| 25 | S = "${WORKDIR}/git" |
| 26 | |
| 27 | inherit pkgconfig autotools-brokensep gettext |
| 28 | |
| 29 | BBCLASSEXTEND += "nativesdk" |
| 30 | |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 31 | EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 32 | |
| 33 | do_configure() { |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 34 | ./bootstrap nosubmodule |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 35 | oe_runconf ${EXTRA_OECONF} |
| 36 | } |
| 37 | |
| 38 | do_install() { |
| 39 | oe_runmake DESTDIR=${D} install |
| 40 | if [ -e "${D}${infodir}" ]; then |
| 41 | rm -Rf ${D}${infodir} |
| 42 | fi |
| 43 | if [ -e "${D}${mandir}" ]; then |
| 44 | rm -Rf ${D}${mandir} |
| 45 | fi |
| 46 | if [ -e "${D}${bindir}/.debug" ]; then |
| 47 | rm -Rf ${D}${bindir}/.debug |
| 48 | fi |
| 49 | } |
| 50 | |
| 51 | FILES_${PN} = " \ |
| 52 | ${datadir}/openocd/* \ |
| 53 | ${bindir}/openocd \ |
| 54 | " |
| 55 | |
| 56 | PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio" |
| 57 | PACKAGECONFIG ??= "sysfsgpio" |