Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Small Footprint CIM Broker" |
| 2 | DESCRIPTION = "\ |
| 3 | Small Footprint CIM Broker (sfcb) is a CIM server conforming to the CIM \ |
| 4 | Operations over HTTP protocol. It is robust, with low resource consumption \ |
| 5 | and therefore specifically suited for embedded and resource constrained \ |
| 6 | environments. sfcb supports providers written against the Common \ |
| 7 | Manageability Programming Interface (CMPI)." |
| 8 | HOMEPAGE = "http://www.sblim.org" |
| 9 | SECTION = "Applications/System" |
| 10 | LICENSE = "EPL-1.0" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261" |
| 12 | DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native" |
| 13 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | inherit distro_features_check |
| 15 | REQUIRED_DISTRO_FEATURES = "pam" |
| 16 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 18 | file://sfcb.service \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 19 | file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \ |
| 20 | file://sblim-sfcb-1.3.15-fix-provider-debugging.patch \ |
| 21 | file://sblim-sfcb-1.3.16-maxMsgLen.patch \ |
| 22 | file://sblim-sfcb-1.4.5-service.patch \ |
| 23 | file://sblim-sfcb-1.3.16-multilib-man-cfg.patch \ |
| 24 | file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \ |
| 25 | file://sblim-sfcb-1.4.9-fix-ftbfs.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 26 | file://0001-include-stdint.h-system-header-for-UINT16_MAX.patch \ |
| 27 | file://0001-Replace-need-for-error.h-when-it-does-not-exist.patch \ |
| 28 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 29 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 30 | SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30" |
| 31 | SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" |
| 32 | |
| 33 | inherit autotools |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 34 | inherit systemd |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 35 | |
| 36 | SYSTEMD_PACKAGES = "${PN}" |
| 37 | SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service" |
| 38 | SYSTEMD_AUTO_ENABLE = "enable" |
| 39 | |
| 40 | LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" |
| 41 | |
| 42 | EXTRA_OECONF = '--enable-debug \ |
| 43 | --enable-ssl \ |
| 44 | --enable-pam \ |
| 45 | --enable-ipv6 \ |
| 46 | CFLAGS="${CFLAGS} -D_GNU_SOURCE"' |
| 47 | |
| 48 | # make all with -j option is unsafe. |
| 49 | PARALLEL_MAKE = "" |
| 50 | |
| 51 | INSANE_SKIP_${PN} = "dev-so" |
| 52 | CONFIG_SITE = "${WORKDIR}/config-site.${P}" |
| 53 | |
| 54 | do_install() { |
| 55 | cp -f ${S}/sfcb.cfg.pre.in ${S}/sfcb.cfg |
| 56 | |
| 57 | oe_runmake DESTDIR=${D} install |
| 58 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 59 | install -d ${D}${systemd_unitdir}/system |
| 60 | install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 61 | |
| 62 | install -d ${D}${sysconfdir}/init.d |
| 63 | mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb |
| 64 | sed -i -e 's/\/var\/lock\/subsys\/sfcb/\/var\/lock\/subsys\/sblim-sfcb/g' ${D}${sysconfdir}/init.d/sblim-sfcb |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 65 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 66 | rm -rf ${D}${libdir}/sfcb/*.la |
| 67 | } |
| 68 | |
| 69 | pkg_postinst_${PN} () { |
| 70 | OPTS="" |
| 71 | |
| 72 | if [ x"$D" != "x" ]; then |
| 73 | OPTS="--root=$D" |
| 74 | if type systemctl >/dev/null 2>/dev/null; then |
| 75 | systemctl $OPTS ${SYSTEMD_AUTO_ENABLE} ${SYSTEMD_SERVICE} |
| 76 | fi |
| 77 | exit 1 |
| 78 | fi |
| 79 | |
| 80 | ${datadir}/sfcb/genSslCert.sh ${sysconfdir}/sfcb |
| 81 | ${bindir}/sfcbrepos -f |
| 82 | } |
| 83 | |
| 84 | FILES_${PN} += "${libdir}/sfcb ${datadir}/sfcb" |
| 85 | FILES_${PN}-dbg += "${libdir}/sfcb/.debug" |
| 86 | |
| 87 | RDEPENDS_${PN} = "perl bash" |