Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 1 | SUMMARY = "Open POWER DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the openpower YAML" |
| 3 | PR = "r1" |
| 4 | |
| 5 | S = "${WORKDIR}/git" |
| 6 | |
| 7 | inherit autotools pkgconfig |
| 8 | inherit obmc-phosphor-license |
| 9 | inherit pythonnative |
Marri Devender Rao | 8dd7798 | 2017-05-29 01:33:26 -0500 | [diff] [blame] | 10 | inherit phosphor-dbus-yaml |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "sdbus++-native" |
| 14 | |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 15 | SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces" |
Andrew Geissler | 02effd2 | 2017-11-06 18:20:03 +0000 | [diff] [blame] | 16 | SRCREV = "2e2264efcb741950a11fe411a1ee54e30a1b1ff2" |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 17 | |
| 18 | DEPENDS_remove_class-native = "sdbus++-native" |
| 19 | DEPENDS_remove_class-nativesdk = "sdbus++-native" |
| 20 | |
| 21 | PACKAGECONFIG ??= "libopenpower_dbus" |
| 22 | PACKAGECONFIG[libopenpower_dbus] = " \ |
| 23 | --enable-libopenpower_dbus, \ |
| 24 | --disable-libopenpower_dbus, \ |
| 25 | systemd sdbusplus, \ |
| 26 | libsystemd sdbusplus \ |
| 27 | " |
| 28 | |
| 29 | PACKAGECONFIG_remove_class-native = "libopenpower_dbus" |
| 30 | PACKAGECONFIG_remove_class-nativesdk = "libopenpower_dbus" |
| 31 | |
| 32 | BBCLASSEXTEND += "native nativesdk" |