Patrick Williams | 1f2b9a4 | 2020-06-11 16:56:16 -0500 | [diff] [blame] | 1 | inherit phosphor-dbus-yaml |
| 2 | |
Patrick Williams | 891b144 | 2020-06-12 06:04:25 -0500 | [diff] [blame] | 3 | LOGGING_YAML_SUBDIRS ??= "${OBMC_ORG_YAML_SUBDIRS}" |
Patrick Williams | 1f2b9a4 | 2020-06-11 16:56:16 -0500 | [diff] [blame] | 4 | |
| 5 | do_install_append() { |
| 6 | for yaml_d in ${LOGGING_YAML_SUBDIRS} ; |
| 7 | do |
| 8 | if [ ! -d ${S}/${yaml_d} ]; |
| 9 | then |
| 10 | continue |
| 11 | fi |
| 12 | |
| 13 | for yaml_f in $(find ${S}/${yaml_d} -name "*.errors.yaml" -or \ |
| 14 | -name "*.metadata.yaml") ; |
| 15 | do |
| 16 | subpath=$(realpath --relative-to=${S} ${yaml_f}) |
| 17 | install -d $(dirname ${D}${yaml_dir}/$subpath) |
| 18 | |
| 19 | install -m 0644 ${yaml_f} ${D}${yaml_dir}/$subpath |
| 20 | done |
| 21 | done |
| 22 | } |