Andrew Geissler | 3e34fba | 2021-03-05 15:21:55 -0600 | [diff] [blame] | 1 | SUMMARY = "CircuitPython driver for motor, stepper, and servo based on PCA9685." |
| 2 | HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_PCA9685" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e7eb6b599fb0cfb06485c64cd4242f62" |
| 5 | |
| 6 | SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_PCA9685.git" |
| 7 | SRCREV = "2780c4102f4c23fbab252aa1198b61ba7e2d1b2c" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit setuptools3 |
| 12 | |
| 13 | DEPENDS += "python3-setuptools-scm-native" |
| 14 | |
| 15 | RDEPENDS_${PN} += " \ |
| 16 | python3-adafruit-blinka \ |
| 17 | python3-adafruit-circuitpython-busdevice \ |
| 18 | python3-adafruit-circuitpython-register \ |
| 19 | python3-core \ |
| 20 | " |