Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 1 | # This recipe allows for a 'bleeding edge' u-boot-xlnx build. |
| 2 | # Since this tree is frequently updated, AUTOREV is used to track its contents. |
| 3 | # |
| 4 | # To enable this recipe, set the following in your machine or local.conf |
| 5 | # PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-xlnx-dev" |
| 6 | |
| 7 | UBRANCH ?= "master" |
| 8 | |
| 9 | include u-boot-xlnx.inc |
| 10 | include u-boot-spl-zynq-init.inc |
| 11 | |
| 12 | LICENSE = "GPLv2+" |
| 13 | LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c" |
| 14 | |
| 15 | SRCREV_DEFAULT = "aebea9d20a5aa32857f320c07ca8f9fd1b3dec1f" |
| 16 | SRCREV ?= "${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/bootloader", "u-boot-xlnx-dev", "${AUTOREV}", "${SRCREV_DEFAULT}", d)}" |
| 17 | |
| 18 | PV = "${UBRANCH}-xilinx-dev+git${SRCPV}" |
| 19 | |
| 20 | # Newer versions of u-boot have support for these |
| 21 | HAS_PLATFORM_INIT ?= " \ |
| 22 | zynq_microzed_config \ |
| 23 | zynq_zed_config \ |
| 24 | zynq_zc702_config \ |
| 25 | zynq_zc706_config \ |
| 26 | zynq_zybo_config \ |
| 27 | " |
| 28 | |