Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame^] | 1 | SUMMARY = "Sysroot poisoning test" |
| 2 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
| 3 | |
| 4 | LICENSE = "MIT" |
| 5 | |
| 6 | inherit nopackages |
| 7 | |
| 8 | # This test confirms that compiling code that searches /usr/include for headers |
| 9 | # will result in compiler errors. This recipe should will fail to build and |
| 10 | # oe-selftest has a test that verifies that. |
| 11 | do_compile() { |
| 12 | touch empty.c |
| 13 | ${CPP} ${CFLAGS} -I/usr/include empty.c |
| 14 | } |
| 15 | |
| 16 | EXCLUDE_FROM_WORLD = "1" |