Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Compact getty terminal handler for virtual consoles only" |
| 2 | SECTION = "console/utils" |
| 3 | HOMEPAGE = "http://sourceforge.net/projects/mingetty/" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame^] | 4 | DESCRIPTION = "This is a small Linux console getty that is started on the Linux text console, asks for a login name and then tranfers over to login directory. Is extended to allow automatic login and starting any app." |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 5 | LICENSE = "GPLv2" |
| 6 | PR = "r3" |
| 7 | |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=0c56db0143f4f80c369ee3af7425af6e" |
| 9 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz" |
| 10 | |
| 11 | SRC_URI[md5sum] = "2a75ad6487ff271424ffc00a64420990" |
| 12 | SRC_URI[sha256sum] = "0f55c90ba4faa913d91ef99cbf5cb2eb4dbe2780314c3bb17953f849c8cddd17" |
| 13 | |
| 14 | # substitute our CFLAGS for "-O2 -Wall -W -pipe" |
| 15 | # |
| 16 | EXTRA_OEMAKE = "CC='${CC}' \ |
| 17 | CFLAGS='${CFLAGS} -D_GNU_SOURCE'" |
| 18 | |
| 19 | do_install(){ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | sed -i -e "s;SBINDIR=/sbin;SBINDIR=$base_sbindir;" ${S}/Makefile |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 21 | install -d ${D}${mandir}/man8 ${D}/${base_sbindir} |
| 22 | oe_runmake install DESTDIR=${D} |
| 23 | } |
| 24 | |
| 25 | inherit update-alternatives |
| 26 | |
| 27 | ALTERNATIVE_${PN} = "getty" |
| 28 | ALTERNATIVE_LINK_NAME[getty] = "${base_sbindir}/getty" |
| 29 | ALTERNATIVE_TARGET[getty] = "${base_sbindir}/mingetty" |
| 30 | ALTERNATIVE_PRIORITY = "10" |