Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "VA-API support to GStreamer" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame^] | 2 | HOMEPAGE = "https://gstreamer.freedesktop.org/" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 3 | DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \ |
| 4 | based plugins for GStreamer and helper libraries: `vaapidecode', \ |
| 5 | `vaapiconvert', and `vaapisink'." |
| 6 | |
| 7 | REALPN = "gstreamer-vaapi" |
| 8 | |
| 9 | LICENSE = "LGPLv2.1+" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" |
| 11 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 12 | SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame^] | 14 | SRC_URI[sha256sum] = "92db98af86f3150d429c9ab17e88d2364f9c07a140c8f445ed739e8f10252aea" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/${REALPN}-${PV}" |
| 17 | DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" |
| 18 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 19 | inherit meson pkgconfig features_check upstream-version-is-even |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
| 21 | REQUIRED_DISTRO_FEATURES ?= "opengl" |
| 22 | |
| 23 | EXTRA_OEMESON += " \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 24 | -Ddoc=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 25 | -Dexamples=disabled \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 26 | -Dtests=enabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | " |
| 28 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | PACKAGES =+ "${PN}-tests" |
| 30 | |
| 31 | # OpenGL packageconfig factored out to make it easy for distros |
| 32 | # and BSP layers to pick either glx, egl, or no GL. By default, |
| 33 | # try detecting X11 first, and if found (with OpenGL), use GLX, |
| 34 | # otherwise try to check if EGL can be used. |
| 35 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \ |
| 36 | bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \ |
| 37 | '', d), d)}" |
| 38 | |
| 39 | PACKAGECONFIG ??= "drm encoders \ |
| 40 | ${PACKAGECONFIG_GL} \ |
| 41 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" |
| 42 | |
| 43 | PACKAGECONFIG[drm] = "-Dwith_drm=yes,-Dwith_drm=no,udev libdrm" |
| 44 | PACKAGECONFIG[egl] = "-Dwith_egl=yes,-Dwith_egl=no,virtual/egl" |
| 45 | PACKAGECONFIG[encoders] = "-Dwith_encoders=yes,-Dwith_encoders=no" |
| 46 | PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/libgl" |
| 47 | PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland wayland-protocols" |
| 48 | PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxrandr libxrender" |
| 49 | |
| 50 | FILES_${PN} += "${libdir}/gstreamer-*/*.so" |
| 51 | FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug" |
| 52 | FILES_${PN}-dev += "${libdir}/gstreamer-*/*.a" |
| 53 | FILES_${PN}-tests = "${bindir}/*" |