Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Libcomps is alternative for yum.comps library (which is for managing rpm package groups)." |
| 2 | HOMEPAGE = "https://github.com/rpm-software-management/libcomps" |
| 3 | DESCRIPTION = "Libcomps is alternative for yum.comps library. It's written in pure C as library and there's bindings for python2 and python3." |
| 4 | LICENSE = "GPL-2.0-only" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | SRC_URI = "git://github.com/rpm-software-management/libcomps.git;branch=master;protocol=https \ |
| 8 | file://0002-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ |
| 9 | " |
| 10 | |
| 11 | SRCREV = "854fbb9fe733b774981e1ffcf825b2d2ce0f8072" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit cmake setuptools3-base |
| 16 | |
| 17 | DEPENDS = "expat libxml2 zlib" |
| 18 | |
| 19 | EXTRA_OECMAKE = "-DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} \ |
| 20 | -DENABLE_DOCS=OFF \ |
| 21 | -DENABLE_TESTS=OFF" |
| 22 | |
| 23 | OECMAKE_SOURCEPATH = "${S}/libcomps" |
| 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |