Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Smart card library and applications" |
| 2 | DESCRIPTION = "OpenSC is a tool for accessing smart card devices. Basic\ |
| 3 | functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO\ |
| 4 | 7816-4 compatible smart card. Encryption and decryption using private\ |
| 5 | keys on the smart card is possible with PKCS\ |
| 6 | such as the FINEID (Finnish Electronic IDentity) card. Swedish Posten\ |
| 7 | eID cards have also been confirmed to work." |
| 8 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 9 | HOMEPAGE = "https://github.com/OpenSC/OpenSC/wiki" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 10 | SECTION = "System Environment/Libraries" |
| 11 | LICENSE = "LGPL-2.0-or-later" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=cb8aedd3bced19bd8026d96a8b6876d7" |
| 13 | |
| 14 | #v0.21.0 |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 15 | SRCREV = "67986eda93a3a359a897f0b0be97f4315dde8d42" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 16 | SRC_URI = "git://github.com/OpenSC/OpenSC;branch=master;protocol=https \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 17 | " |
| 18 | DEPENDS = "virtual/libiconv openssl" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | inherit autotools pkgconfig bash-completion |
| 22 | |
| 23 | EXTRA_OECONF = " \ |
| 24 | --disable-static \ |
| 25 | --disable-ctapi \ |
| 26 | --disable-doc \ |
| 27 | --disable-strict \ |
| 28 | " |
| 29 | EXTRA_OEMAKE = "DESTDIR=${D}" |
| 30 | |
| 31 | PACKAGECONFIG ??= "pcsc" |
| 32 | |
| 33 | PACKAGECONFIG[openct] = "--enable-openct,--disable-openct,openct" |
| 34 | PACKAGECONFIG[pcsc] = "--enable-pcsc,--disable-pcsc,pcsc-lite,pcsc-lite pcsc-lite-lib" |
| 35 | |
| 36 | RDEPENDS:${PN} = "readline" |
| 37 | |
| 38 | FILES:${PN} += "\ |
| 39 | ${libdir}/opensc-pkcs11.so \ |
| 40 | ${libdir}/onepin-opensc-pkcs11.so \ |
| 41 | ${libdir}/pkcs11-spy.so \ |
| 42 | " |
| 43 | FILES:${PN}-dev += "\ |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 44 | ${libdir}/onepin-opensc-pkcs11.so \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 45 | ${libdir}/pkcs11/opensc-pkcs11.so \ |
| 46 | ${libdir}/pkcs11/onepin-opensc-pkcs11.so \ |
| 47 | ${libdir}/pkcs11/pkcs11-spy.so \ |
| 48 | " |
| 49 | |
| 50 | BBCLASSEXTEND = "native" |