Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Very high-quality data compression program" |
| 2 | DESCRIPTION = "bzip2 compresses files using the Burrows-Wheeler block-sorting text compression algorithm, and \ |
| 3 | Huffman coding. Compression is generally considerably better than that achieved by more conventional \ |
| 4 | LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors." |
Brad Bishop | 220d553 | 2018-08-14 00:59:39 +0100 | [diff] [blame] | 5 | HOMEPAGE = "https://sourceware.org/bzip2/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 6 | SECTION = "console/utils" |
| 7 | LICENSE = "bzip2" |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame^] | 8 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;endline=37;md5=600af43c50f1fcb82e32f19b32df4664" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame^] | 10 | SRC_URI = "https://sourceware.org/pub/${BPN}/${BPN}-${PV}.tar.gz \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | file://configure.ac;subdir=${BP} \ |
| 12 | file://Makefile.am;subdir=${BP} \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 13 | file://run-ptest \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 14 | " |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame^] | 15 | SRC_URI[md5sum] = "67e051268d0c475ea773822f7500d0e5" |
| 16 | SRC_URI[sha256sum] = "ab5a03176ee106d3f0fa90e381da478ddae405918153cca248e682cd0c4a2269" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame^] | 18 | UPSTREAM_CHECK_URI = "https://www.sourceware.org/pub/bzip2/" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | UPSTREAM_VERSION_UNKNOWN = "1" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 20 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 21 | PACKAGES =+ "libbz2" |
| 22 | |
| 23 | CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64" |
| 24 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 25 | inherit autotools update-alternatives ptest relative_symlinks |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 26 | |
| 27 | ALTERNATIVE_PRIORITY = "100" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | ALTERNATIVE_${PN} = "bunzip2 bzcat bzip2" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 29 | |
| 30 | #install binaries to bzip2-native under sysroot for replacement-native |
| 31 | EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}" |
| 32 | |
| 33 | do_install_ptest () { |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 34 | sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile |
| 35 | } |
| 36 | |
| 37 | FILES_libbz2 = "${libdir}/lib*${SOLIBS}" |
| 38 | |
Brad Bishop | 393846f | 2019-05-20 12:24:11 -0400 | [diff] [blame] | 39 | RDEPENDS_${PN}-ptest += "make" |
| 40 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 41 | PROVIDES_append_class-native = " bzip2-replacement-native" |
| 42 | BBCLASSEXTEND = "native nativesdk" |