Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Video Acceleration (VA) API for Linux" |
| 2 | DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \ |
| 3 | and API specification which enables and provides access to graphics \ |
| 4 | hardware (GPU) acceleration for video processing on Linux and UNIX \ |
| 5 | based operating systems. Accelerated processing includes video \ |
| 6 | decoding, video encoding, subpicture blending and rendering. The \ |
| 7 | specification was originally designed by Intel for its GMA (Graphics \ |
| 8 | Media Accelerator) series of GPU hardware, the API is however not \ |
| 9 | limited to GPUs or Intel specific hardware, as other hardware and \ |
| 10 | manufacturers can also freely use this API for hardware accelerated \ |
| 11 | video decoding." |
| 12 | |
| 13 | HOMEPAGE = "https://01.org/linuxmedia/vaapi" |
| 14 | BUGTRACKER = "https://github.com/intel/libva/issues" |
| 15 | |
| 16 | SECTION = "x11" |
| 17 | LICENSE = "MIT" |
| 18 | LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f" |
| 19 | |
| 20 | SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2" |
| 21 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame^] | 22 | SRC_URI[md5sum] = "3688212fb7a87947070f3729e91ff7cf" |
| 23 | SRC_URI[sha256sum] = "3aa89cd369a506ac4dbe5de7c0ef5da4f3d220bf986403f02fa1f6f702af6878" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
| 25 | UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases" |
| 26 | |
| 27 | DEPENDS = "libdrm virtual/mesa" |
| 28 | |
| 29 | inherit autotools pkgconfig distro_features_check |
| 30 | |
| 31 | REQUIRED_DISTRO_FEATURES = "opengl" |
| 32 | |
| 33 | EXTRA_OECONF = "ac_cv_prog_WAYLAND_SCANNER=wayland-scanner" |
| 34 | |
| 35 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" |
| 36 | PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes" |
| 37 | PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland" |
| 38 | |
| 39 | PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland" |
| 40 | |
| 41 | RDEPENDS_${PN}-x11 =+ "${PN}" |
| 42 | RDEPENDS_${PN}-glx =+ "${PN}-x11" |
| 43 | |
| 44 | FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}" |
| 45 | FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}" |
| 46 | FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}" |