blob: 1d9ca9daae022dc95af1371ace90aa7fde2866c5 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
2DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \
3serialization format. It includes libprotobuf-c, a pure C library that \
4implements protobuf encoding and decoding, and protoc-c, a code generator that \
5converts Protocol Buffer .proto files to C descriptor code, based on the \
6original protoc. protobuf-c formerly included an RPC implementation; that code \
7has been split out into the protobuf-c-rpc project."
8HOMEPAGE = "https://github.com/protobuf-c/protobuf-c"
9SECTION = "console/tools"
10LICENSE = "BSD-2-Clause"
Andrew Geissler615f2f12022-07-15 14:00:58 -050011LIC_FILES_CHKSUM = "file://LICENSE;md5=9f725889e0d77383e26cb42b0b62cea2"
Andrew Geisslereff27472021-10-29 15:35:00 -050012
13DEPENDS = "protobuf-native protobuf"
14
Andrew Geissler220dafd2023-10-04 10:18:08 -050015SRC_URI = "git://github.com/protobuf-c/protobuf-c.git;branch=next;protocol=https"
16SRC_URI:append:class-native = " file://0001-Makefile.am-do-not-compile-the-code-which-was-genera.patch"
17
18SRCREV = "ba4c55f0e686e0252c451f7163ab529e4b36831a"
Andrew Geisslereff27472021-10-29 15:35:00 -050019
20S = "${WORKDIR}/git"
21
22inherit autotools pkgconfig
23
Andrew Geissler595f6302022-01-24 19:11:47 +000024export PROTOC = "${STAGING_BINDIR_NATIVE}/protoc"
25
Andrew Geisslereff27472021-10-29 15:35:00 -050026# After several fix attempts there is still a race between generating
27# t.test-full.pb.h and compiling cxx_generate_packed_data.c despite
28# BUILT_SOURCES and explicit dependencies.
29PARALLEL_MAKE = ""
30
31PACKAGE_BEFORE_PN = "${PN}-compiler"
32
33FILES:${PN}-compiler = "${bindir}"
34
35RDEPENDS:${PN}-compiler = "protobuf-compiler"
36RDEPENDS:${PN}-dev += "${PN}-compiler"
37
38BBCLASSEXTEND = "native nativesdk"