Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "x86 (SSE) assembler supporting NASM and GAS-syntaxes" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 2 | LICENSE = "MIT" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 3 | HOMEPAGE = "http://www.tortall.net/projects/yasm/" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=a12d8903508fb6bfd49d8d82c6170dd9" |
| 6 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 7 | DEPENDS += "flex-native bison-native" |
| 8 | PACKAGECONFIG[docs] = ",,xmlto-native," |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | |
| 10 | PV = "1.3.0+git${SRCPV}" |
| 11 | # v1.3.0 |
| 12 | SRCREV = "ba463d3c26c0ece2e797b8d6381b161633b5971a" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | SRC_URI = "git://github.com/yasm/yasm.git;branch=master;protocol=https \ |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 14 | file://0001-Do-not-use-AC_HEADER_STDC.patch \ |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 15 | file://CVE-2023-31975.patch \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 16 | file://CVE-2023-37732.patch \ |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 17 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | inherit autotools gettext python3native |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 22 | |
| 23 | CACHED_CONFIGUREVARS = "CCLD_FOR_BUILD='${CC_FOR_BUILD}'" |
| 24 | |
| 25 | BBCLASSEXTEND = "native" |
| 26 | |
| 27 | PARALLEL_MAKE = "" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 28 | |
| 29 | do_configure:prepend() { |
| 30 | # Don't include $CC (which includes path to sysroot) in generated header. |
| 31 | sed -i -e "s/^echo \"\/\* generated \$ac_cv_stdint_message \*\/\" >>\$ac_stdint$"// ${S}/m4/ax_create_stdint_h.m4 |
| 32 | } |