Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Yet Another Flash File System" |
| 2 | DESCRIPTION = "Tools for managing 'yaffs2' file systems." |
| 3 | |
| 4 | SECTION = "base" |
| 5 | HOMEPAGE = "http://www.yaffs.net" |
| 6 | |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://utils/mkyaffs2image.c;beginline=12;endline=14;md5=5f5464f9b3e981ca574e65b00e438561" |
| 9 | |
| 10 | PV = "0.0+git${SRCPV}" |
| 11 | |
| 12 | DEPENDS = "mtd-utils" |
| 13 | |
| 14 | # Source is the HEAD of master branch at the time of writing this recipe |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 15 | SRC_URI = "git://www.aleph1.co.uk/yaffs2;protocol=git;branch=master \ |
| 16 | file://makefile-add-ldflags.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 17 | file://0001-define-loff_t-if-not-already-defined.patch \ |
| 18 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 19 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | SRCREV = "bc76682d93955cfb33051beb503ad9f8a5450578" |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | CFLAGS_append = " -I.. -DCONFIG_YAFFS_UTIL -DCONFIG_YAFFS_DEFINES_TYPES" |
| 24 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 25 | |
| 26 | do_compile() { |
| 27 | cd utils && oe_runmake |
| 28 | } |
| 29 | |
| 30 | INSTALL_FILES = "mkyaffsimage \ |
| 31 | mkyaffs2image \ |
| 32 | " |
| 33 | do_install() { |
| 34 | install -d ${D}${sbindir}/ |
| 35 | for i in ${INSTALL_FILES}; do |
| 36 | install -m 0755 utils/$i ${D}${sbindir}/ |
| 37 | done |
| 38 | } |
| 39 | |
| 40 | BBCLASSEXTEND = "native" |