Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "A simple, sane and efficient module to slurp a file" |
| 2 | DESCRIPTION = "This module provides functions for fast and correct slurping and spewing. \ |
| 3 | All functions are optionally exported. All functions throw exceptions on \ |
| 4 | errors, write functions don't return any meaningful value." |
| 5 | |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 8 | |
| 9 | HOMEPAGE= "https://metacpan.org/release/File-Slurper" |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \ |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame^] | 12 | file://${COMMON_LICENSE_DIR}/GPL-1.0-or-later;md5=30c0b8a5048cc2f4be5ff15ef0d8cf61" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 13 | |
| 14 | SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/File-Slurper-${PV}.tar.gz" |
| 15 | |
| 16 | SRC_URI[md5sum] = "5742c63096392dfee50b8db314bcca18" |
| 17 | SRC_URI[sha256sum] = "4efb2ea416b110a1bda6f8133549cc6ea3676402e3caf7529fce0313250aa578" |
| 18 | RDEPENDS_${PN} = " \ |
| 19 | perl-module-carp \ |
| 20 | perl-module-encode \ |
| 21 | perl-module-exporter \ |
| 22 | perl-module-perlio \ |
| 23 | perl-module-perlio-encoding \ |
| 24 | perl-module-strict \ |
| 25 | perl-module-warnings \ |
| 26 | " |
| 27 | |
| 28 | RDEPENDS_${PN}-ptest += "libtest-warnings-perl \ |
| 29 | perl-module-test-more \ |
| 30 | " |
| 31 | |
| 32 | S = "${WORKDIR}/File-Slurper-${PV}" |
| 33 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 34 | inherit cpan ptest-perl |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 35 | |
| 36 | BBCLASSEXTEND = "native" |