Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "WebKit based web browser for GNOME" |
| 2 | DESCRIPTION = "Epiphany is an open source web browser for the Linux desktop environment. \ |
| 3 | It provides a simple and easy-to-use internet browsing experience." |
| 4 | HOMEPAGE = "https://wiki.gnome.org/Apps/Web" |
| 5 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/epiphany" |
| 6 | LICENSE = "GPL-3.0-or-later" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | |
| 9 | DEPENDS = " \ |
| 10 | webkitgtk \ |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 11 | gcr \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | gsettings-desktop-schemas \ |
| 13 | nettle \ |
| 14 | json-glib \ |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 15 | libadwaita \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 16 | libarchive \ |
| 17 | libdazzle \ |
| 18 | libhandy \ |
| 19 | libportal \ |
| 20 | libsoup \ |
| 21 | glib-2.0-native \ |
| 22 | coreutils-native \ |
| 23 | desktop-file-utils-native \ |
| 24 | " |
| 25 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 26 | inherit gnomebase gsettings features_check gettext mime-xdg gtk-icon-cache |
| 27 | REQUIRED_DISTRO_FEATURES = "x11 opengl" |
| 28 | |
| 29 | SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@oe.utils.trim_version("${PV}", 1)}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \ |
| 30 | file://0002-help-meson.build-disable-the-use-of-yelp.patch \ |
| 31 | file://migrator.patch \ |
| 32 | file://distributor.patch \ |
| 33 | " |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 34 | SRC_URI[archive.sha256sum] = "f4348f2cf51c07c0c106d130172d4d23f2cd4068771e1de007b758ca2ade5660" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 35 | |
| 36 | # Developer mode enables debugging |
| 37 | PACKAGECONFIG[developer-mode] = "-Ddeveloper_mode=true,-Ddeveloper_mode=false" |
| 38 | |
| 39 | FILES:${PN} += "${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers ${datadir}/metainfo" |
| 40 | RDEPENDS:${PN} = "iso-codes adwaita-icon-theme gsettings-desktop-schemas" |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 41 | |
| 42 | # ANGLE requires SSE support as of webkit 2.40.x on 32 bit x86 |
| 43 | COMPATIBLE_HOST:x86 = "${@bb.utils.contains_any('TUNE_FEATURES', 'core2 corei7', '.*', 'null', d)}" |