Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "a fast C/C++ compiler cache" |
| 2 | DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \ |
| 3 | by caching the result of previous compilations and detecting when the \ |
| 4 | same compilation is being done again. Supported languages are C, C\+\+, \ |
| 5 | Objective-C and Objective-C++." |
| 6 | HOMEPAGE = "http://ccache.samba.org" |
| 7 | SECTION = "devel" |
| 8 | |
| 9 | LICENSE = "GPL-3.0-or-later" |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=9896d6f0aee4d89b9e5ff0afaae0af06" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 11 | |
| 12 | DEPENDS = "zstd" |
| 13 | |
| 14 | SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BP}.tar.gz \ |
| 15 | file://0001-xxhash.h-Fix-build-with-gcc-12.patch \ |
| 16 | " |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 17 | SRC_URI[sha256sum] = "12834ecaaaf2db069dda1d1d991f91c19e3274cc04a471af5b64195def17e90f" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 18 | |
| 19 | inherit cmake github-releases |
| 20 | |
| 21 | PATCHTOOL = "patch" |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |
| 24 | |
| 25 | PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc" |
| 26 | PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis" |