blob: 45c988117bd1c6a694a1413a3ae872730c3b8766 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=5279a7ab369ba336989dcf2a107e5c8e"
10
11PYPI_PACKAGE = "GitPython"
12
13inherit pypi python_setuptools_build_meta
14
Patrick Williams44b3caf2024-04-12 16:51:14 -050015SRC_URI[sha256sum] = "35f314a9f878467f5453cc1fee295c3e18e52f1b99f10f6cf5b1682e968a9e7c"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060016
Patrick Williams73bd93f2024-02-20 08:07:48 -060017DEPENDS += " python3-gitdb"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060018
19RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060020 python3-datetime \
21 python3-gitdb \
22 python3-io \
23 python3-logging \
24 python3-math \
25 python3-netclient \
26 python3-stringold \
27 python3-unittest \
28 python3-unixadmin \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060029 git \
30"
31
32BBCLASSEXTEND = "native nativesdk"