Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Zstandard - Fast real-time compression algorithm" |
| 2 | DESCRIPTION = "Zstandard is a fast lossless compression algorithm, targeting \ |
| 3 | real-time compression scenarios at zlib-level and better compression ratios. \ |
| 4 | It's backed by a very fast entropy stage, provided by Huff0 and FSE library." |
| 5 | HOMEPAGE = "http://www.zstd.net/" |
| 6 | SECTION = "console/utils" |
| 7 | |
| 8 | LICENSE = "BSD-3-Clause & GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c7f0b161edbe52f5f345a3d1311d0b32 \ |
| 10 | file://COPYING;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0" |
| 11 | |
| 12 | SRC_URI = "git://github.com/facebook/zstd.git;nobranch=1" |
| 13 | |
Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 14 | SRCREV = "a3d655d2255481333e09ecca9855f1b37f757c52" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 15 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | PACKAGECONFIG ??= "" |
| 20 | PACKAGECONFIG[lz4] = "HAVE_LZ4=1,HAVE_LZ4=0,lz4" |
| 21 | PACKAGECONFIG[lzma] = "HAVE_LZMA=1,HAVE_LZMA=0,xz" |
| 22 | PACKAGECONFIG[zlib] = "HAVE_ZLIB=1,HAVE_ZLIB=0,zlib" |
| 23 | |
| 24 | # See programs/README.md for how to use this |
| 25 | ZSTD_LEGACY_SUPPORT ??= "4" |
| 26 | |
| 27 | do_compile () { |
| 28 | oe_runmake ${PACKAGECONFIG_CONFARGS} ZSTD_LEGACY_SUPPORT=${ZSTD_LEGACY_SUPPORT} |
| 29 | } |
| 30 | |
| 31 | do_install () { |
| 32 | oe_runmake install 'DESTDIR=${D}' |
| 33 | } |
| 34 | |
| 35 | BBCLASSEXTEND = "native nativesdk" |