Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Abseil is a cpp library like STL" |
| 2 | DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \ |
| 3 | additional useful libraries like algorithm, container, debugging, hash, memory, \ |
| 4 | meta, numeric, strings, synchronization, time, types and utility" |
| 5 | HOMEPAGE = "https://abseil.io/" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915" |
| 9 | |
Patrick Williams | 975a06f | 2022-10-21 14:42:47 -0500 | [diff] [blame] | 10 | PV = "20221014.0" |
| 11 | SRCREV = "5fa65f28e46e86c44966a1ca8a727a329d9c1ff8" |
| 12 | BRANCH = "master" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \ |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 14 | file://0001-absl-always-use-asm-sgidefs.h.patch \ |
| 15 | file://0002-Remove-maes-option-from-cross-compilation.patch \ |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 16 | file://abseil-ppc-fixes.patch \ |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 17 | file://0003-Remove-neon-option-from-cross-compilation.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | " |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | ASNEEDED:class-native = "" |
| 23 | ASNEEDED:class-nativesdk = "" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | |
| 25 | inherit cmake |
| 26 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 27 | EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \ |
| 28 | -DBUILD_TESTING=OFF \ |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 29 | -DCMAKE_CXX_STANDARD=14 \ |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 30 | " |
| 31 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | FILES:${PN}-dev += "${includedir} ${libdir}/cmake ${libdir}/pkgconfig" |