Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "SPIRV-Cross is a tool designed for parsing and converting SPIR-V \ |
| 2 | to other shader languages" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 5 | SECTION = "graphics" |
| 6 | |
| 7 | S = "${WORKDIR}/git" |
| 8 | SRCREV = "ed16b3e69985feaf565efbecea70a1cc2fca2a58" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | SRC_URI = "git://github.com/KhronosGroup/SPIRV-Cross.git;branch=master;protocol=https \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | file://0001-Add-install-PHONY-target-in-Makefile.patch \ |
| 11 | " |
| 12 | |
| 13 | EXTRA_OEMAKE += 'TARGET_DIR_LIB="${D}${libdir}"' |
| 14 | EXTRA_OEMAKE += 'TARGET_DIR_BIN="${D}${bindir}"' |
| 15 | |
| 16 | do_compile () { |
| 17 | cd ${S} && oe_runmake |
| 18 | } |
| 19 | |
| 20 | do_install () { |
| 21 | cd ${S} && oe_runmake install |
| 22 | } |