Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Simple Go-based setuid+setgid+setgroups+exec" |
| 2 | HOMEPAGE = "https://github.com/tianon/gosu" |
| 3 | DESCRIPTION = "This is a simple tool grown out of the simple fact that su and sudo have very strange and often annoying TTY and signal-forwarding behavior." |
| 4 | LICENSE = "Apache-2.0 " |
| 5 | LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 6 | |
| 7 | GO_IMPORT = "github.com/tianon/gosu" |
| 8 | SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \ |
| 9 | git://github.com/opencontainers/runc;name=runc;destsuffix=${S}/src/github.com/opencontainers/runc;branch=main;protocol=https \ |
| 10 | " |
| 11 | SRCREV = "9f7cd138a1ebc0684d43ef6046bf723978e8741f" |
| 12 | SRCREV_runc = "d7f7b22a85a2387557bdcda125710c2506f8d5c5" |
| 13 | inherit go |
| 14 | |
| 15 | do_compile:prepend() { |
| 16 | # New Go versions has Go modules support enabled by default |
| 17 | export GO111MODULE=off |
| 18 | } |
| 19 | |
| 20 | RDEPENDS:${PN}-dev += "bash" |