Jayanth Othayoth | 7ebc36e | 2021-06-21 07:20:21 -0500 | [diff] [blame] | 1 | SUMMARY = "To get required hardware procedure attribute xml files" |
| 2 | DESCRIPTION = "Copy all the required hardware procedures attributes xml file \ |
| 3 | with respective directory structures" |
| 4 | |
| 5 | PR = "r1" |
| 6 | PV = "1.0+git${SRCPV}" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE_PROLOG;md5=d8e5f403c98fd80dcea90b9cc8cd083c" |
| 9 | |
| 10 | require ekb.inc |
| 11 | |
| 12 | SRC_URI = "${EKB_URI}" |
| 13 | SRCREV = "${EKB_REV}" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | BBCLASSEXTEND = "native" |
| 18 | |
| 19 | do_install() { |
| 20 | |
| 21 | mkdir -p ${D}${datadir}/${BPN} |
| 22 | |
| 23 | # Copying all required hwp's attributes xml file with respective directory structures |
| 24 | (cd ${S} && cp --parents ${REQ_ATTRS_XMLS} ${D}${datadir}/${BPN}) |
| 25 | } |