George Hung | 58253a8 | 2020-06-11 21:20:11 +0800 | [diff] [blame] | 1 | DESCRIPTION = "Report CPLD Version" |
| 2 | PR = "r1" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | |
| 6 | inherit systemd |
| 7 | |
| 8 | SRC_URI = " file://cpld_version.sh \ |
| 9 | file://cpld-version.service \ |
| 10 | " |
| 11 | |
| 12 | S = "${WORKDIR}" |
| 13 | |
| 14 | DEPENDS = "systemd" |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 15 | RDEPENDS:${PN} = "bash" |
George Hung | 58253a8 | 2020-06-11 21:20:11 +0800 | [diff] [blame] | 16 | |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 17 | SYSTEMD_SERVICE:${PN} = "cpld-version.service" |
George Hung | 58253a8 | 2020-06-11 21:20:11 +0800 | [diff] [blame] | 18 | |
| 19 | do_install() { |
| 20 | install -d ${D}${bindir} |
| 21 | install -m 0755 ${S}/cpld_version.sh ${D}${bindir}/ |
| 22 | |
| 23 | install -d ${D}${systemd_system_unitdir} |
| 24 | install -m 0644 ${S}/cpld-version.service ${D}${systemd_system_unitdir} |
| 25 | } |