George Hung | f089ba1 | 2020-05-20 17:22:25 +0800 | [diff] [blame] | 1 | PR = "r1" |
| 2 | LICENSE = "Apache-2.0 & BSD-3-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10 \ |
| 4 | file://${COREBASE}/meta/files/common-licenses/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9 \ |
| 5 | " |
| 6 | |
| 7 | inherit systemd |
| 8 | inherit obmc-phosphor-systemd |
| 9 | |
| 10 | |
| 11 | DEPENDS += "systemd" |
| 12 | DEPENDS += "phosphor-ipmi-flash" |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 13 | RDEPENDS:${PN} += "bash" |
George Hung | f089ba1 | 2020-05-20 17:22:25 +0800 | [diff] [blame] | 14 | |
George Hung | e60f2ac | 2021-05-20 18:53:06 +0800 | [diff] [blame] | 15 | PROVIDES += "virtual/bios-update" |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 16 | RPROVIDES:${PN} += "virtual/bios-update" |
George Hung | e60f2ac | 2021-05-20 18:53:06 +0800 | [diff] [blame] | 17 | |
George Hung | f089ba1 | 2020-05-20 17:22:25 +0800 | [diff] [blame] | 18 | SRC_URI += " file://bios-verify.sh \ |
| 19 | file://bios-update.sh \ |
| 20 | file://phosphor-ipmi-flash-bios-verify.service \ |
| 21 | file://phosphor-ipmi-flash-bios-update.service \ |
| 22 | file://config-bios.json \ |
| 23 | " |
| 24 | |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 25 | FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-bios.json" |
George Hung | f089ba1 | 2020-05-20 17:22:25 +0800 | [diff] [blame] | 26 | |
| 27 | do_install() { |
| 28 | install -d ${D}${bindir} |
| 29 | install -m 0755 ${WORKDIR}/bios-verify.sh ${D}${bindir}/ |
| 30 | install -m 0755 ${WORKDIR}/bios-update.sh ${D}${bindir}/ |
| 31 | |
| 32 | install -d ${D}${systemd_system_unitdir} |
| 33 | install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-verify.service ${D}${systemd_system_unitdir} |
| 34 | install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-update.service ${D}${systemd_system_unitdir} |
| 35 | |
| 36 | install -d ${D}${datadir}/phosphor-ipmi-flash |
| 37 | install -m 0644 ${WORKDIR}/config-bios.json ${D}${datadir}/phosphor-ipmi-flash |
| 38 | } |
| 39 | |
| 40 | |
| 41 | SYSTEMD_PACKAGES = "${PN}" |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 42 | SYSTEMD_SERVICE:${PN} = "phosphor-ipmi-flash-bios-verify.service phosphor-ipmi-flash-bios-update.service" |