Patrick Williams | 53961c2 | 2022-01-20 11:06:23 -0600 | [diff] [blame] | 1 | SUMMARY = "CHIPSEC: Platform Security Assessment Framework" |
| 2 | |
| 3 | DESCRIPTION = "CHIPSEC is a framework for analyzing the security \ |
| 4 | of PC platforms including hardware, system firmware \ |
| 5 | (BIOS/UEFI), and platform components." |
| 6 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 7 | LICENSE = "GPL-2.0-only" |
Patrick Williams | 53961c2 | 2022-01-20 11:06:23 -0600 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=bc2d1f9b427be5fb63f6af9da56f7c5d" |
| 9 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 10 | DEPENDS = "virtual/kernel nasm-native" |
Patrick Williams | 53961c2 | 2022-01-20 11:06:23 -0600 | [diff] [blame] | 11 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 12 | SRC_URI = "git://github.com/chipsec/chipsec.git;branch=main;protocol=https" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 13 | SRCREV = "fd1a98688978fd4b8ca77b512a72eae49c3beffa" |
Patrick Williams | 53961c2 | 2022-01-20 11:06:23 -0600 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
Patrick Williams | 53961c2 | 2022-01-20 11:06:23 -0600 | [diff] [blame] | 16 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 17 | inherit module setuptools3 |
Patrick Williams | 53961c2 | 2022-01-20 11:06:23 -0600 | [diff] [blame] | 18 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 19 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'" |
| 20 | |
Patrick Williams | 53961c2 | 2022-01-20 11:06:23 -0600 | [diff] [blame] | 21 | do_compile:append() { |
| 22 | cd ${S}/drivers/linux |
| 23 | oe_runmake KSRC=${STAGING_KERNEL_BUILDDIR} |
| 24 | } |
| 25 | |
| 26 | do_install:append() { |
| 27 | install -m 0644 ${S}/drivers/linux/chipsec.ko ${D}${PYTHON_SITEPACKAGES_DIR}/chipsec/helper/linux |
| 28 | } |
| 29 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 30 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" |
| 31 | |
| 32 | FILES:${PN} += "${exec_prefix}" |
| 33 | |
| 34 | RDEPENDS:${PN} = "python3 python3-modules" |