Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "Exports a gssapi interface which calls other gssapi libraries" |
| 2 | DESCRIPTION = "\ |
| 3 | This library exports a gssapi interface, but does not implement any gssapi \ |
| 4 | mechanisms itself; instead it calls gssapi routines in other libraries, \ |
| 5 | depending on the mechanism. \ |
| 6 | " |
| 7 | |
| 8 | HOMEPAGE = "http://www.citi.umich.edu/projects/nfsv4/linux/" |
| 9 | SECTION = "libs" |
| 10 | |
| 11 | LICENSE = "BSD-3-Clause | HPND" |
| 12 | |
| 13 | #Copyright (c) 1996, by Sun Microsystems, Inc. HPND |
| 14 | #Copyright (c) 2007 The Regents of the University of Michigan. BSD-3-Clause |
| 15 | #Copyright 1995 by the Massachusetts Institute of Technology. HPND without Disclaimer |
| 16 | #Copyright 1993 by OpenVision Technologies, Inc. HPND |
| 17 | LIC_FILES_CHKSUM = "file://COPYING;md5=56871e72a5c475289c0d5e4ba3f2ee3a \ |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 18 | file://src/g_accept_sec_context.c;beginline=3;endline=23;md5=da8ca7a37bd26e576c23874d453751d2\ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 19 | file://src/g_ccache_name.c;beginline=1;endline=32;md5=208d4de05d5c8273963a8332f084faa7 \ |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 20 | file://src/oid_ops.c;beginline=1;endline=26;md5=1f194d148b396972da26759a8ec399f0\ |
| 21 | file://src/oid_ops.c;beginline=378;endline=398;md5=d77a5c03e91908fac453c08bbeaddce1\ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 22 | " |
| 23 | |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 24 | SRC_URI = "${DEBIAN_MIRROR}/main/libg/${BPN}/${BPN}_${PV}.orig.tar.gz \ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 25 | file://libgssglue-canon-name.patch \ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 26 | " |
| 27 | |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 28 | SRC_URI[sha256sum] = "bcd618ae0bc69f12815d77295658a760e7edc20706b9a731a81da8993f5c970a" |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 29 | |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 30 | inherit autotools-brokensep |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 31 | |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 32 | do_configure:prepend() { |
| 33 | cd ${S} |
| 34 | ./bootstrap |
| 35 | } |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | do_install:append() { |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 38 | # install some docs |
| 39 | install -d -m 0755 ${D}${docdir}/${BPN} |
| 40 | install -m 0644 ${S}/AUTHORS ${S}/ChangeLog ${S}/NEWS ${S}/README ${D}${docdir}/${BPN} |
| 41 | |
| 42 | # install the gssapi_mech.conf |
| 43 | install -d -m 0755 ${D}${sysconfdir} |
| 44 | install -m 0644 ${S}/doc/gssapi_mech.conf ${D}${sysconfdir} |
| 45 | |
| 46 | # change the libgssapi_krb5.so path and name(it is .so.2) |
| 47 | sed -i -e "s:/usr/lib/libgssapi_krb5.so:libgssapi_krb5.so.2:" ${D}${sysconfdir}/gssapi_mech.conf |
| 48 | } |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 49 | |
| 50 | # gssglue can use krb5, spkm3... as gssapi library, configurable |
| 51 | RRECOMMENDS:${PN} += "krb5" |