Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | DEPENDS:append:class-target = " ${PYTHON_PN}-native ${PYTHON_PN}" |
| 8 | DEPENDS:append:class-nativesdk = " ${PYTHON_PN}-native ${PYTHON_PN}" |
| 9 | RDEPENDS:${PN}:append:class-target = " ${PYTHON_PN}-core" |
| 10 | |
| 11 | export STAGING_INCDIR |
| 12 | export STAGING_LIBDIR |
| 13 | |
| 14 | # LDSHARED is the ld *command* used to create shared library |
| 15 | export LDSHARED = "${CCLD} -shared" |
| 16 | # LDXXSHARED is the ld *command* used to create shared library of C++ |
| 17 | # objects |
| 18 | export LDCXXSHARED = "${CXX} -shared" |
| 19 | # CCSHARED are the C *flags* used to create objects to go into a shared |
| 20 | # library (module) |
| 21 | export CCSHARED = "-fPIC -DPIC" |
| 22 | # LINKFORSHARED are the flags passed to the $(CC) command that links |
| 23 | # the python executable |
| 24 | export LINKFORSHARED = "${SECURITY_CFLAGS} -Xlinker -export-dynamic" |
| 25 | |
| 26 | FILES:${PN} += "${libdir}/* ${libdir}/${PYTHON_DIR}/*" |
| 27 | |
| 28 | FILES:${PN}-staticdev += "\ |
| 29 | ${PYTHON_SITEPACKAGES_DIR}/*.a \ |
| 30 | " |
| 31 | FILES:${PN}-dev += "\ |
| 32 | ${datadir}/pkgconfig \ |
| 33 | ${libdir}/pkgconfig \ |
| 34 | ${PYTHON_SITEPACKAGES_DIR}/*.la \ |
| 35 | " |
| 36 | inherit python3native python3targetconfig |
| 37 | |