Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "XCB: The X protocol C binding library" |
| 2 | DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \ |
| 3 | for Xlib featuring a small footprint, latency hiding, direct access to \ |
| 4 | the protocol, improved threading support, and extensibility." |
| 5 | HOMEPAGE = "http://xcb.freedesktop.org" |
| 6 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB" |
| 7 | SECTION = "x11/libs" |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7" |
| 11 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 12 | SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.xz \ |
| 13 | file://0001-use-_Alignof-to-avoid-UB-in-ALIGNOF.patch" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "4348566aa0fbf196db5e0a576321c65966189210cb51328ea2bb2be39c711d71" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | |
| 17 | BBCLASSEXTEND = "native nativesdk" |
| 18 | |
| 19 | DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp" |
| 20 | |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 21 | PACKAGES_DYNAMIC = "^${PN}-.*" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | FILES:${PN} = "${libdir}/libxcb.so.*" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 25 | inherit autotools pkgconfig features_check |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 26 | |
| 27 | # The libxau and others requires x11 in DISTRO_FEATURES |
| 28 | REQUIRED_DISTRO_FEATURES = "x11" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | |
| 30 | export PYTHON = "python3" |
| 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | do_install:append () { |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 33 | chown root.root ${D}${datadir}/doc/${BPN}/tutorial -R |
| 34 | } |
| 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | python populate_packages:prepend () { |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 37 | do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', '${PN}-%s', 'XCB library module for %s', allow_links=True) |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 38 | } |