Xo Wang | 4ef18bf | 2016-10-24 18:44:49 -0700 | [diff] [blame] | 1 | DESCRIPTION = "Command line tools for hardware device registers" |
Patrick Venture | 7507209 | 2017-10-05 15:11:30 -0700 | [diff] [blame] | 2 | HOMEPAGE = "https://github.com/jonmayergoogle/iotools" |
Patrick Williams | d541ec5 | 2022-04-30 07:41:26 -0500 | [diff] [blame] | 3 | LICENSE = "GPL-2.0-or-later" |
Xo Wang | 4ef18bf | 2016-10-24 18:44:49 -0700 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
Brad Bishop | 3a3497c | 2018-03-30 12:27:37 -0400 | [diff] [blame] | 5 | SRCREV = "8d928b3360246b8ead95b442ca3887ce8b8f942f" |
Xo Wang | 4ef18bf | 2016-10-24 18:44:49 -0700 | [diff] [blame] | 6 | PV = "v1.6+git${SRCPV}" |
| 7 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame^] | 8 | SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https;branch=master" |
Patrick Venture | f5952ed | 2017-10-05 16:25:40 -0700 | [diff] [blame] | 9 | |
Xo Wang | 4ef18bf | 2016-10-24 18:44:49 -0700 | [diff] [blame] | 10 | S = "${WORKDIR}/git" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame^] | 11 | SYSTEMD_SERVICE:${PN} += "iotools-setup.service" |
| 12 | |
| 13 | inherit obmc-phosphor-systemd |
Xo Wang | 4ef18bf | 2016-10-24 18:44:49 -0700 | [diff] [blame] | 14 | |
| 15 | do_compile() { |
| 16 | # CC is overridden in the Makefile, so override it harder in the invocation |
| 17 | oe_runmake CC="${CC}" DEBUG="${DEBUG_BUILD-0}" STATIC=0 |
| 18 | } |
Xo Wang | 4ef18bf | 2016-10-24 18:44:49 -0700 | [diff] [blame] | 19 | # The "install" make target runs the binary to create links for subcommands. |
| 20 | # The links are excessive and this doesn't work for cross compiling. |
| 21 | do_install() { |
| 22 | install -d ${D}${sbindir} |
| 23 | install -m 0755 iotools ${D}${sbindir} |
| 24 | } |
Patrick Venture | f5952ed | 2017-10-05 16:25:40 -0700 | [diff] [blame] | 25 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame^] | 26 | FILES:${PN} = "${sbindir}" |